Started 21 days ago03 August 2026Lasted about 3 hours03 August 202612:273:27 PMUTC
Affected
๐ Octotel Fibre
Partial outage from 12:27 PM to 10:00 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Investigating
UTC
Investigating
UTC
Please note that Octotel have identified an issue on their network affecting services around the Strand area. Octotel technicians are currently investigating. More updates to follow.