Openserve - Grassy Park / Ottery - Scheduled Maintenance 2
Completed
Scheduled for 14 April 2026 at 8:00 PM โย 15 April 2026 at 6:00 AM
Affects
๐ฆ Openserve Fibre
Under maintenance from 8:00 PM to 6:00 AM
Updates
Completed
15 April 2026 at 6:00 AM
Completed
15 April 2026 at 6:00 AM
Maintenance has completed successfully
In progress
14 April 2026 at 8:00 PM
In progress
14 April 2026 at 8:00 PM
Maintenance is now in progress
Planned
14 April 2026 at 8:00 PM
Planned
14 April 2026 at 8:00 PM
Please note that Openserve will be conducting planned maintenance on their infrastructure in the Grassy Park and Ottery areas. Customers may experience disruptions in service.