Started about 1 year ago26 May 2025Lasted 2 days26 May 20257:27 PM28 May 20258:03 PMUTC
Updates
Resolved
UTC
Resolved
UTC
The incident has been resolved
Investigating
UTC
Investigating
UTC
We have a ticket open with Frogfoot about backhaul network congestion for the Tokai & Kirstenhof areas.
They confirmed there is a problem and are busy investigating.