๐ IP Transit 1 experiencing degraded performance
Alert - Octotel - Strand
Resolved
Partial outage
Started 8 months ago22 December 2025Lasted about 8 hours22 December 20257:31 AM3:35 PMUTC
Updates
Resolved
UTC
Resolved
UTC
The incident has been resolved
Investigating
UTC
Investigating
UTC
Please note that Octotel have identified service impact to some customers in the Strand area. Their technicians are currently investigating. More updates to follow.